注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

熊猫正正的博客

熊猫正正的天空

 
 
 

日志

 
 

mac上安装cocos2d出错解决  

2013-09-23 21:20:05|  分类: ios游戏开发 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
1,显示Mac上的隐藏文件
defaults write com.apple.finder AppleShowAllFiles -bool true

关闭隐藏文件
defaults write com.apple.finder AppleShowAllFiles -bool false


2,今天更新下模板,发现使用./install-templates.sh -f 命令进行安装cocos2d 2.0 模板,总是返回以下信息
  1. LiumatoMac-mini:cocos2d-iphone-2.0 liuyanghui$ sudo ./install-templates.sh  
  2. cocos2d-iphone template installer  
  3.   
  4. Error: Do not run this script as root.  
  5.   
  6. 'root' is no longer supported  
  7.   
  8. RECOMMENDED WAY:  
  9.  ./install-templates.sh -f

我已经是root权限了,但是脚本总是不能识别我使用的root权限安装。看了下脚本,发现是几句代码在验证:

  1. # Make sure root is not executed  
  2. if [[ "$(id -u)" == "0" ]]; then  
  3.     echo ""  
  4.     echo "Error: Do not run this script as root." 1>&2  
  5.     echo ""  
  6.     echo "'root' is no longer supported" 1>&2  
  7.     echo ""  
  8.     echo "RECOMMENDED WAY:" 1>&2  
  9.     echo " $0 -f" 1>&2  
  10.     echo ""  
  11. exit 1  
  12. fi

所以把这段判决root权限对脚本代码去掉

然后使用命令 sudo sh ./install-templates.sh -f 进行安装。此时发现可以安装成功了。

如果出现输入password的话,就输入password。

  评论这张
 
阅读(48)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017