注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

熊猫正正的博客

熊猫正正的天空

 
 
 

日志

 
 

XCode5下安装cocos2d模板及不能成功安装的解决办法  

2014-02-19 18:50:57|  分类: ios游戏开发 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
转自:http://blog.csdn.net/chaoyuan899/article/details/17435389

第一步,现在要安装集成环境xcode5,安装xcode5需要系统至少是os x 10.8.5。

    第二步,下载cocos2d-iphone到电脑文档或任何一个文件夹(这里以文档为例),

   下载地址:http://code.google.com/p/cocos2d-iphone/downloads/list

     第三步,打开终端,先利用命令进入当前的 “cd documents” 进入Documents文件夹,然后“cd cocos2d-iphone-1.0.0” 进入cocos2d引擎文件夹,最后“./install-templates.sh -u”命令开始安装cocos2d。(红色部分为自己下载的文件名)

   第四步,打开xcode-creat new project。看到如图所示画面

点击next,建立第一个cocos项目。xcode点击左上方的。模拟器会自动生成helloworld!


按照以上步骤安装,有些可能会出现以下的提示错误:

出现这样的提示,是因为没有足够的权限创建一个新的文件夹,你可以手动在以上提示的路径创建一个文件夹,命名为以上提示的文件名(如这里的是 cocos2d  v2.x),然后在终端输入 ./install-templates.sh -u -f ,安装成功后,会在该文件夹下出现很多子文件夹,如下:

最后打开 XCode,新建一个工程的时候就可以看到模板安装成功了。

  评论这张
 
阅读(47)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017